Woocommerce and non-latin characters problem

This is a PRIVATE forum for verified users only, to view all replies/answers, you must be logged in!

Status: not resolved
  • This topic has 12 replies, 3 voices, and was last updated 4 y, 3 mo by  moserlx.
Viewing 12 reply threads
  • Author
    Posts
    • #8387

      moserlx
      Member

      Hello I have this problem:

      I have installed and setting up Sparkle theme and I use the woocommerce feature too. When I create a product and I want to add variations, if the varation name is in Greek language, it doesnt appear in the menu in product page.

      When I change template it is working perfect. Here are some screenshots:

      https://imgur.com/a/SoLmJ

      As you see in screenshots, when the fields “name” and/or “value(s)” are in Greek, they dont appear in product page.

      Can you please fix this or guide me how to fix it?

    • #8391

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #8399

      moserlx
      Member
      This reply has been marked as private.
    • #8415

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #8427

      moserlx
      Member
      This reply has been marked as private.
    • #8454

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #8468

      moserlx
      Member

      You are right, It seems that the problem is caused when the name in attributes is in greek and not the values. If you change the name to something greek it doesnt work

      http://wp.noikokyra.gr/product/kainourio-proion/

      • This reply was modified 4 y, 3 mo by  moserlx.
      • This reply was modified 4 y, 3 mo by  moserlx.
    • #8508

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #8547

      moserlx
      Member

      But with the same version of WP and Woocommerce and using another template, our current eshop has no problem.

      WP 4.1.1 and Woocommerce 2.3.7

      http://eshop.noikokyra.gr/product/alysida-alouminiou-megalh-se-4-xrwmata/

      I created an account with same login info, if you want to check by yourself.

    • #8556

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #8560

      moserlx
      Member

      This is not correct. Exactly the same product is working on old template but it is no working in Sparkle:

      http://wp.noikokyra.gr/product/formes-keik-silikonhs/

      http://eshop.noikokyra.gr/product/formes-keik-silikonhs/

      They both have “X” in their variation name.

      My client uses woocommerce for more than 2 years and never had a problem like this. We discovered this problem when we starting developing the new version of this website using sparkle theme. In wp.noikokyra.gr feel free to make any modifications or tests you like, I have a backup.

    • #8568

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #8577

      moserlx
      Member

      I would really appreciate it if you could help me. I will contact server administrator too.

Viewing 12 reply threads
  • You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view all replies/answers, you must be logged in!

© Copyright 2019 by wpthms.com. All Rights Reserved.