Styling options won’t work

This is a PRIVATE forum for verified users only, to view all replies/answers, you must be logged in!

Status: resolved
Viewing 55 reply threads
  • Author
    Posts
    • #618

      debiesven
      Member

      When I change the built-in skins to lime-green, it will be saved in the theme options, but nothing changes on the webite itself.

    • #624

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #638

      presto
      Member

      I am having the same problem on my site. I’ve tried both picking themes as well as picking custom colors and nothing changes. The site is http://davidseebach.com/magic/

    • #640

      debiesven
      Member

      My site is http://www.coro-zonnepanelen.nl/wordpress/

      I think it has something to with the basepath, because it is both in a subdirectory.

    • #644

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #647

      nidrig
      Member

      hi,
      I have the same problem here. No matter where I change the colors, everything remain the same.
      I shall mention that the installation is on a subdirectory, as the previous members have posted.
      Third edit: all icons are missing, too. I guess there is sth wrong with subdirectories installation and css.

      • This reply was modified 7 y, 4 mo by  nidrig.
      • This reply was modified 7 y, 4 mo by  nidrig.
      • This reply was modified 7 y, 4 mo by  nidrig.
      • This reply was modified 7 y, 4 mo by  nidrig.
    • #649

      debiesven
      Member

      When I add some custom css, it does nothing too. I can’t find it in de loaded css files.

    • #651

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #652

      nidrig
      Member
      This reply has been marked as private.
    • #667

      nidrig
      Member

      It seems that none of the styling options are working. The font change isn’t taken into account either.

    • #671

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #672

      nidrig
      Member

      ok. I changed the permissions of creatiz/css/custom-styles.css to 777, as well as the parent folder, but that doesn’t change anything.

    • #673

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #674

      nidrig
      Member

      Nope. Doesn’t work either.

    • #675

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #676

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #677

      nidrig
      Member

      Sorry, but this website is on a private server with Plesk. So I cannot grant you access to the webserver.

      While exploring with firebug, I found that the css that contains the missing icons is referred to this path: demo.wpthms.com/creatiz/wp-content/uploads/2013/5/creatiz.css (hardcoded?)
      Besides, the custom-styles.css file is never modified, no matter what permissions.

      I don’t know what this plugin is, and please, can you make the reply private, when it contains URL? Thanks.

      I’ll try a fresh install on a new repository.

      • This reply was modified 7 y, 4 mo by  nidrig.
      • This reply was modified 7 y, 4 mo by  nidrig.
    • #679

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #680

      nidrig
      Member

      I did a fresh install on a new db. I only installed the required plugins. I didn’t import anything, no demo data, no theme configuration. I granted permission to the custom css file and whole theme folder.

      But the same problem remains; the theme option are not saved.

    • #681

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #686

      nidrig
      Member

      Yes, I just did that and have the same issue.

    • #687

      presto
      Member

      On my installation these are all editable and I’m still not seeing any updates go through.

      – Appearance -> editor
      – Plugins – Editor
      – Settings -> Permalinks -> try switching and hit save changes

      I’ve also done a fresh install with no luck. Anything else I can try?

    • #690

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #693

      wpthms
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #695

      presto
      Member

      I’ve tried with my primary color empty and not empty neither option makes any difference.

    • #696

      nidrig
      Member

      “You should contact your hosting provider and tell them about your issue. Our site work properly without any issue on Stablehost!”

      And what I am suppose to say to my host provider?

      “Your site asked for FTP info. when we try installing new plugin, this is due to server configuration totally.”

      All my wp installations ask for the FTP credentials when a new plugin needs to be installed. I enter the credential, then the plugins are installed without problem. It is standard WP config, what’s the point with that? And what has it to do with the theme? All required plugins have been installed anyway.

      I’ve installed countless WP themes on this server with this configuration and never had any issue. I’ve also installed themes which used dynamic css rewriting for the options, and they work well. This is the first theme with which I have such a problem.

      Could you please try to make a fresh install on your side, on a subdirectory? Then maybe we could nail down what the issue is.

      I would really appreciate if you could make some effort to help us find the issue, because several people experience it, obviously.

    • #762

      debiesven
      Member

      I just installed the theme again, with the latest updates. But it’s still not working properly.

      Is there a fix allready? Can you try it yourself, by installing it on a subdirectory. I think that’s the problem.

    • #763

      nidrig
      Member

      What I did, and the problem is still present:

      – install on localhost
      – fresh install
      – no data import
      – install on another host provider
      – install on the root of the domain (no subdirectory)
      – grant permissions to all wp-content

      Are there people out there where the saving of the options (colors and typography) do work?

    • #764

      debiesven
      Member

      I get this error, when i start debugging.

      WP_Filesystem_FTPext Object
      (
          [link] =>
          [errors] => WP_Error Object
              (
                  [errors] => Array
                      (
                          [empty_hostname] => Array
                              (
                                  [0] => FTP hostname is required
                              )

                          [empty_username] => Array
                              (
                                  [0] => FTP username is required
                              )

                          [empty_password] => Array
                              (
                                  [0] => FTP password is required
                              )

                      )

                  [error_data] => Array
                      (
                      )

              )

          [options] => Array
              (
                  [port] => 21
                  [ssl] =>
              )

          [verbose] =>
          [cache] => Array
              (
              )

          [method] => ftpext
      )

    • #765

      debiesven
      Member

      I changes the following lines in theme-styling.php:58

      /** Write to css file **/
      WP_Filesystem();
      global $wp_filesystem;
      if ( ! $wp_filesystem->put_contents( $aq_uploads_dir . ‘custom-styles.css’, $css, 0644) ) {
      return true;

      to

      file_put_contents($aq_uploads_dir . ‘custom-styles.css’,$css);

      And it’s fixed. But it isn’t a good fix. You guys should privde a better one.

    • #767

      wpthms
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #771

      wpthms
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #773

      wpthms
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #804

      debiesven
      Member

      Entering the FTP credentials is a good way to do so. But asking your hoster isn’t a fix. Try to remember that.

    • #814

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #819

      nidrig
      Member

      Hi,
      I’ve updated to the latest version 1.0.4.

      I set up the ftp credentials in the wp-config.php. and that part works fine because I can install plugins without being asked for credentials.

      I gave 777 rights to the css folder as well as custom-styles.css.

      But that still doesn’t work, neither the colors nor the fonts changes are saved.

      The only thing that worked was the correction from debiesven.

      You mention php.ini, what should we look for there?

    • #873

      vandimarco
      Member

      Hi,

      Sorry but I strated my same question when I bought this template 1 week ago in Themeforest website and the only answer was to go to this forum and now we are 3 to ask the same questions again 
       !!!

      So please, please could you answer cleary why we couldn’t change the color and the fonts with your template ???

      For my pat it’s for a customer and I need a profesionnal from you…

      Regards

    • #881

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #885

      vandimarco
      Member
      This reply has been marked as private.
    • #889

      keyhanjun
      Member

      Hi vandimarco,

      please edit your post immediately! You forget to check the option called ‘Set as private reply’!

      This way the content of your post would be only visible to You & the staff. Now it’s visible for everyone participating in this forum – not good… 😉

      Best regards,
      keyhanjun

    • #891

      wpthms
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #892

      wpthms
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #1407

      Any stable solution yet ? Thanks.

    • #1685

      luenez
      Member

      I am having the same problem. My color themes will not load up nor change. My website is character builders.co

    • #1687

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #1698

      luenez
      Member

      I am not sure what you mean by #892

    • #1699

      luenez
      Member

      I copied the php file and it still is doing the same thing. I cant change to the color option I want

    • #1710

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #1718

      phlpalxndr
      Member

      What do you mean “make sure that the file permission of “creatiz/CSS/custom-styles.CSS is 755 or 777” ???

    • #1719

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #1727

      phlpalxndr
      Member
      This reply has been marked as private.
    • #1770

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #1987

      pcconnect
      Member
      This reply has been marked as private.
    • #2100

      sSerenity
      Member
      This reply has been marked as private.
    • #2109

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #2115

      sSerenity
      Member

      now, it’s working….Thank’s you

Viewing 55 reply threads
  • You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view all replies/answers, you must be logged in!

© Copyright 2020 by wpthms.com. All Rights Reserved.