Posts appearing on both hero blocks and latest news

This is a PRIVATE forum for verified users only, to view all replies/answers, you must be logged in!

Status: resolved
Viewing 40 reply threads
  • Author
    Posts
    • #16552

      rfischmann
      Member

      This is my homepage: https://macmagazine.uol.com.br/

      I’ve just noticed that posts from the hero block are also appearing right below in latest news. That’s not good.

      Any way to set it up in a way that posts don’t appear twice in the homepage?

      Cheers.

    • #16591

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #16601

      rfischmann
      Member

      That seemed to good to be true. 😛

      I’ve installed and activated it. Don’t see any change to my homepage, posts are still being duplicated.

    • #16603

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #16607

      rfischmann
      Member

      Thank you so much. I’ll uninstall it for now, then.

    • #16689

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #16691

      rfischmann
      Member

      Thanks a lot, Jacob. It seems to be working, but still need some tweaks — I’ve removed it from our site, for now.

      As you know, we have a 6-post hero block in the top that pulls posts from our “Destaques” category. Then, we have 3 lines with a total of 12 latest posts, then 3 videos, then 3 columns with 3 other special categories, and then we have once again a list with 10 additional latest posts (with a “More” button) that we offset by 12.

      Your code is probably not taking that into consideration, as I missed a couple of posts that should appear there.

      Cheers.

    • #16698

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #16706

      rfischmann
      Member

      Awesome! It seems to be perfect now.

    • #17062

      rfischmann
      Member

      Jacob, I’ve just noticed that when I click to load more posts on the bottom of our homepage, it’s loading the latest posts that already appear above — not the correct ones that should load continuously.

      Can you advise, please?

    • #17063

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17072

      rfischmann
      Member

      Oh, that’s very bad Jacob. Any suggestions? Maybe another method of loading more posts on my homepage?

    • #17079

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17088

      rfischmann
      Member

      Don’t know what you mean. The hero banner has featured posts, then I have a few different sections with posts from tags or categories, and also all the latest posts.

    • #17092

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17096

      rfischmann
      Member

      Got it, but it wouldn’t work well on our case as we have those 6 spots for featured posts in the top and then, as soon as we add the 7th, the last should “go down” to the other sections. If I do as you said, the featured posts would only appear in the hero banner.

    • #17152

      rfischmann
      Member

      I really need help on this. My homepage is broken because of it.

    • #17164

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17165

      rfischmann
      Member

      Broken in the sense that it’s not working as it should. The “load more” button isn’t loading the correct posts, so people can’t browse my site as it’s intended to be.

    • #17188

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17191

      rfischmann
      Member

      I hope it will work! Thanks.

    • #17449

      Antonin F
      Member

      I have the same problem with duplicated posts showing on the homepage. Where are you supposed to put the code above? Thanks.

    • #17452

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17477

      Antonin F
      Member

      Thanks! Keep it going. You have a great theme.

    • #17479

      Antonin F
      Member

      So I have to use child’s theme, right?

    • #17496

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17571

      rfischmann
      Member

      Any news? This is very serious.

    • #17582

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17586

      rfischmann
      Member

      Sorry, I don’t understand.

    • #17627

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17628

      rfischmann
      Member

      Well I’d accept some duplicated posts in a complex scenario like that. But it should work just fine on mine.

    • #17818

      rfischmann
      Member

      It’s been months and my homepage is still “broken” because of this.

    • #17867

      rfischmann
      Member

      Another issue I’ve had for almost 6 months now. This is really bad.

    • #17905

      rfischmann
      Member

      Any reply here?

    • #17910

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17913

      rfischmann
      Member

      In the first test, it didn’t load anything at all: https://d.pr/i/ICmPRe

      It seems that same Ajax issue we’ve discussed before related to nonce cookies or something.

      After one refresh, it worked. And it seems to be great, finally!

    • #17915

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17930

      rfischmann
      Member

      One more question, Jacob; with this new plugin you’ve installed, should I remove that custom code you wrote before from my custom-functions.php file?

    • #17933

      jadeuhoje
      Member

      where can i find custom-functions.php ?

    • #17939

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #17945

      rfischmann
      Member

      Okay!

Viewing 40 reply threads
  • You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view all replies/answers, you must be logged in!

© Copyright 2020 by wpthms.com. All Rights Reserved.