Menu error Warning: Invalid argument supplied for foreach() in on line 483

This is a PRIVATE forum for verified users only, to view all replies/answers, you must be logged in!

Status: not resolved

Tagged: 

  • This topic has 3 replies, 2 voices, and was last updated 7 y, 7 mo by  Max.
Viewing 3 reply threads
  • Author
    Posts
    • #1931

      I’m having troubles with my menu. 

      Warning: Invalid argument supplied for foreach() in /public/sites/www.socialpicture.nl/wp-content/themes/creatiz/functions/theme-interface.php on line 483

      On line 483 it says:

      480  //$scrollspy_menu[‘wrap-all’] = __(‘Top’,’framework’);
      481 if($page_meta_data){
      482 $page_section_id = 0;
      483 foreach($page_meta_data as $kmeta => $v) {
      $columnType = isset($v[‘data_column_type’]) ? $v[‘data_column_type’] : ”;
      $columnName = isset($v[‘data_column_name’]) ? $v[‘data_column_name’] : ”;
      if($columnType === ‘Page Section’){
      $scrollspy_menu[‘page-section-‘ . $page_section_id] =  $columnName;
      $page_section_id++;
      }
      }
      }

      What is going wrong and how do I fix it?

    • #1951

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #1980

      Fixed it. Test site was using 1.0.6 and the ‘live’ site was still on 1.0.5.

    • #1983

      Max
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

Viewing 3 reply threads
  • You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view all replies/answers, you must be logged in!

© Copyright 2021 by wpthms.com. All Rights Reserved.