Instagram widget not updating

This is a PRIVATE forum for verified users only, to view all replies/answers, you must be logged in!

Status: not resolved
Viewing 47 reply threads
  • Author
    Posts
    • #18753

      rfischmann
      Member

      I’ve just noticed the Instagram widget on our site’s footer isn’t updating anymore. We’ve posted a few photos in the past few weeks and it’s frozen.

      Help?

    • #18757

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18760

      rfischmann
      Member

      Didn’t seem to have fixed the issue for me.

    • #18763

      rfischmann
      Member

      I’m also seeing this on my error logs:

      [03-Sep-2020 08:06:23 UTC] PHP Warning: DOMDocument::loadHTML(): Empty string supplied as input in /home/macmagazine/public_html/wp-content/plugins/wp-social-counter/inc/services/instagram.php on line 33

    • #18764

      rfischmann
      Member

      Actually, it took a while but the footer widget did update now.

    • #18767

      rfischmann
      Member

      Something’s off, it has now reverted back to the previous old cached widget.

    • #18776

      rfischmann
      Member

      Still waiting as well.

    • #18787

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18797

      rfischmann
      Member

      And nope, this is not working fine at all.

    • #18803

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18808

      where is new update Last Update 24 July 20

    • #18810

      rfischmann
      Member

      It’s not a browser issue, I’ve checked. It’s still outdated, you can check it yourself.

    • #18813

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18815

      rfischmann
      Member

      Yes, I’m also seeing it updated now. However, when I replied yesterday, it wasn’t showing the last 3 photos.

    • #18818

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18819

      rfischmann
      Member

      I do have a caching plugin, but it regenerates all pages every 4 hours. That’s not the issue, then — the oldest of those 3 photos that I wasn’t seeing yesterday was posted more than a week ago.

    • #18820

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18821

      rfischmann
      Member

      Ok.

    • #18824

      rfischmann
      Member

      Once again it’s showing up outdated: https://d.pr/i/dWTS7c

      I’ve checked in another browser and in an incognito window.

    • #18827

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18829

      rfischmann
      Member

      Seems to have fixed it, let’s see if it stays always updated now.

    • #18835

      rfischmann
      Member

      It’s back to that previous state, very old images.

    • #18921

      rfischmann
      Member

      This issue persists. Sometimes it shows updated images, sometimes it seems that it pulls and old cache somehow. I’m now missing 3 images on our homepage that were posted many days ago.

    • #18943

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18945

      rfischmann
      Member

      It’s not a Cloudflare thing, I’ve checked. And Cloudflare is set to refresh all caches every 30 minutes, anyway.

      This is for sure a bug in the plugin.

    • #18957

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18960

      rfischmann
      Member

      I already said I’ve tested that. There’s no need to disable a caching system “for a few days”, I can manually clear the cache of any page whenever I want so it’s regenerated on the fly. And I’ve done that, and the widget was still outdated.

      It’s something else, and I strongly believe it’s a bug in the plugin.

    • #18963

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18966

      rfischmann
      Member

      The plugin has its own cache, doesn’t it? How does it work? Where does it store it?

    • #18968

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18969

      rfischmann
      Member
    • #18970

      rfischmann
      Member

      BTW, the widget is totally outdated on our site. The last photo it shows is from more than a week ago; we’ve posted 4 photos after that one.

    • #18974

      rfischmann
      Member

      You really should update the noticed on the top of these support pages. You rarely, almost never reply tickets in 24-48 hours.

    • #18986

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #18997

      rfischmann
      Member
      This reply has been marked as private.
    • #19010

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #19018

      rfischmann
      Member
      This reply has been marked as private.
    • #19033

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #19037

      im also using instagram widget its working fine, im on cloudflare ( respect httpd headers and + WP Rocket (12 hours cache) Refresh website every post updated its working fine

    • #19038

      rfischmann
      Member

      Go ahead, Jacob.

    • #19049

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #19052

      rfischmann
      Member

      Thanks, let’s see how it goes now.

    • #19054

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #19060

      rfischmann
      Member

      I’m not seeing the widget anymore on my homepage.

    • #19062

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #19065

      rfischmann
      Member

      It doesn’t matter if you are in incognito or not. As I’ve already told you, all our public pages are cached by Cloudflare.

      I was also seeing it earlier today, like you did. Now it’s gone again.

    • #19092

      Jacob
      Staff

      Hey there, You must be logged in to view this reply!

      Login | Register | Forgot Password?

    • #19103

      rfischmann
      Member

      It probably means Instagram is blocking our site’s requests as the plugin isn’t caching anything, then it simply disappears for a while. I’m not seeing it right now: https://d.pr/i/1HGT3X

      You should rethink how its caching feature works, there’s something wrong there.

Viewing 47 reply threads
  • You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view all replies/answers, you must be logged in!

© Copyright 2021 by wpthms.com. All Rights Reserved.