Warning; Invalid argument

This topic is: Not resolved

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!

This topic contains 12 replies, has 2 voices, and was last updated by  dagger 2 years, 11 months ago.

  • Author
    Posts
  • #2101

    dagger
    Member
    Post count: 42

    Afternoon;

    1 )I had received this warning before, and thought I had done somthing wrong to the source code. I re-installed WordPress and the Theme, and same problem?

    Warning: Invalid argument supplied for foreach() in /home/timereac/public_html/wordpress/wp-content/themes/creatiz/functions/theme-interface.php on line 483

  • #2102

    dagger
    Member
    Post count: 42
    This reply has been marked as private.
  • #2103

    dagger
    Member
    Post count: 42

    I made another adjustment to the homepage ) I cloned it) and I now have the attached images errors

  • #2104

    dagger
    Member
    Post count: 42

    I made another adjustment to the homepage ) I cloned it) and I now have the attached images errors (attempt 2 due to image size)

  • #2110

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #2114

    dagger
    Member
    Post count: 42

    Please note that I am having the same error on all 3 browsers ( Chrome, Firefox and Internet Explorer 11) It cannot be a browser cache issue, as I never use Internet Explorer.The 2nd set of errors (line 38) concerne me the most, as they happen anytime that you use pagebuilder.

    It is frustrating to see that other people are having this same error, and you are not able to fix it. This is a great theme, and prior to your update, the theme worked fine. I think that even thought you may feel it is everyone elses’ problem, sometimes you need to look at yourself. You have not sold many of your themes, so it might be a good idea to review code, as there may be legitimate bugs and you are just blaming it on others?

  • #2118

    dagger
    Member
    Post count: 42

    It is not a caching issue, but is directly related to the pagebuilder. I had my developer look at the errors I listed on my thread, and even fixed the line 38 errors with the following fix, but pagebuilder still doesn’t work properly. These errors only happened when you updated your theme, so in order to keep any sense of credibility, stop telling us that we are all wrong, and that it works perfectly for you.

    Warning: Invalid argument supplied for foreach() in /home/public_html/wordpress/wp-content/themes/creatiz/functions/theme-content-generator.php on line 38

    Line 38 is:

    If ($page_meta_data) {

    Needs to be changed to

    if(is_array($page_meta_data) && sizeof($page_meta_data)) {

    Needs to check if $page_meta_data is an array and that there are values within it, otherwise foreach() will display a warning.

    —-And not that even after this fix that removes the array errors, pagebuilder still doesn’t work right.

  • #2119

    dagger
    Member
    Post count: 42

    Further to this comment, I checked on one site we have using v 1.0.5, and the pagebuilder works fine. I suggest that you give everyone that is having the v1.0.6 pagebuilder issue the option to download 1.0.5

  • #2131

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #2133

    dagger
    Member
    Post count: 42
    This reply has been marked as private.
  • #2137

    dagger
    Member
    Post count: 42

    Evening Mann;

    So it’s been a few days since I gave you the opportunity with a brand new wordpress configuration and database. Seems like it’s easier to tell me what I am not doing right, than to show me that it is NOT an error of the theme?

  • #2138

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #2139

    dagger
    Member
    Post count: 42

    Thanks, I will start to do some work on it and keep you posted.

    Regards,
    Allan

You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!