Translation – Please Help!!!

This topic is: Resolved

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!

This topic contains 3 replies, has 2 voices, and was last updated by  brugravem 5 months, 1 week ago.

  • Author
    Posts
  • #14666

    brugravem
    Member
    Post count: 4

    Hey! This is my first time creating a blog and the theme is really easy to use, so thanks for that!

    However I’m going crazy trying to translate parts of the theme.
    I’ve read how to translate from Documentation and read tons of posts in this forum.
    I’ve already tried Poedit and Loco Translator plugins.
    I’ve uninstalled the theme and then installed it again.
    I also downloaded Poedit and translated everything I wanted, but I can never make it work in the site.

    I’m pretty sure there is something very basic that I’m doing wrong and that’s why I can’t translate my theme, but I’m really new at this so I don’t know what to do.

    So, here is my situation:
    I have already translated everything with Predator to a duplicated file named “pt_BR.po” and “pt_BR.mo”. Both files are in my computer in yeahthemes-elegance/languages.
    – I’ve already tried naming the files yeahthemes-pt_BR.po and yeahthemes-pt_BR.mo but it didn’t make a difference
    – I’ve already tried pasting a code into the functions.php file in /yeahthemes-elegance (I’ve read in this forum it could solve my problem though I’m not sure how it would help since I’m using the childtheme and the childtheme doesn’t have a language folder)

    This is a really stupid question but do I have to upload something (.po ou .mo ou function.php) or do something in wordpress to make the translations work? Because from what I understand, all this .po .mo functions.php are done in my computer and not on the wordpress admin website, so it’s all offline, right?

  • #14667

    brugravem
    Member
    Post count: 4

    Okay, so now I know how to upload the .po and .mo.
    I did that, changed the ‘WPLANG’, ‘pt_BR’.
    I also added this code to custom-functions.php in my themechild:

    add_action(‘after_setup_theme’, ‘my_theme_setup’);
    function my_child_theme_setup() {
    load_child_theme_textdomain( ‘yeahthemes’, get_stylesheet_directory() . ‘/languages’ );
    }

    And I made a languages file in the theme child with original and translated .mo and .po
    And it still doesn’t work!
    I’m going crazy!!!!
    Can anyone help???

  • #14668

    Jacob
    Staff
    Post count: 2533

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #14674

    brugravem
    Member
    Post count: 4

    It worked!!!!
    Thank you so much!!!! =D

You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!