I can no longer save theme options

This topic is: Not resolved

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!

Tagged: ,

This topic contains 8 replies, has 3 voices, and was last updated by  Max 5 months ago.

  • Author
    Posts
  • #14027

    nakri
    Member
    Post count: 1

    I’m on WordPress 4.5.3, but the problem persists in the newest 4.6 release. The XOXO version is 1.0.9.

    On the page “Theme options” I’ve changed the Custom logo under “General Settings”, but when I try to click “Save All Changes” or “Save and Refresh” i just get a notification which says “Error”.

    Debuging just a little I see that the Ajax call with admin-ajax.php goes through with a 200, but the response for the call is the FTP “update page” for WordPress with the text:

    “Connection Information

    To perform the requested action, WordPress needs to access your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host.”

    … and so on.

    Any idea what I can do to resolve this. I can no longer save any changes to the theme.

    Thanks in advance.

  • #14076

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #14093

    Sn4ke87
    Member
    Post count: 3

    Hi i Have the same problem that i always get the massage “error” if i want to save the settings. additional to that i cant change the theme colour. What can I do?

    thx

  • #14094

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #14095

    Sn4ke87
    Member
    Post count: 3
    This reply has been marked as private.
  • #14097

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #14098

    nakri
    Member
    Post count: 1

    I’m running my own linux machine using Nginx to host WordPress, so I’d rather not have FTP running at all, if I can help it.

    My issue was resolved by making the nginx user the owner of the entire WordPress installation directory. I suspect this is too permissive, but I’m not sure which files the theme requires write access to.

    Anyway, thanks for the help.

  • #14101

    Sn4ke87
    Member
    Post count: 3

    hi i tried both solutions: ftp details in my wp-config and the custom-functions.php adds. Nothing worked :-/ I also changed the file permissions to 777 but this didnt worked at all. What else can i do?

  • #14110

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!