Fatal error: Allowed memory size of 134217728 bytes exhausted

This topic is: Not resolved

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!

Tagged: ,

This topic contains 9 replies, has 3 voices, and was last updated by  Jacob 1 year, 5 months ago.

  • Author
    Posts
  • #9858

    shalomanov
    Member
    Post count: 47

    Guys, I’ve got message
    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 22751719 bytes) in /var/www/…/wp-includes/wp-db.php on line 1094

    And I can’t beat it.

    define( ‘WP_MEMORY_LIMIT’, ’64M’ );
    memory_limit = 128M
    WP Super Cache activated

    I think that’s more than enough for WP.

    So I want to know how to reduce memory usage. Not how to improve my hosting, but how to reduce memory usage. For example I want to stop caching css in database.

  • #9883

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #9890

    shalomanov
    Member
    Post count: 47

    Hi, Maxxi.
    This issue happens occasionally during regular website functioning. Saving changes with theme options is the only way to restore the website working.
    With debug mode off – just blank screen.

    I don’t use megamenu.

    http://travelever.com/

  • #9898

    Jacob
    Staff
    Post count: 2312

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #9919

    shalomanov
    Member
    Post count: 47

    Jacob, my site is fine, because I press “Save Changes” to revive it twice a day. And I’m not going to do it forever. Error log is sent.

    Guys, why don’t you just answer my question: how to turn off caching css in database.

  • #9993

    shalomanov
    Member
    Post count: 47

    Any news, guys?

  • #10022

    shalomanov
    Member
    Post count: 47

    Support is not your strong point, right?

  • #10033

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #10040

    shalomanov
    Member
    Post count: 47

    Maxxi, thanks.
    I think, I got it.
    I couldn’t save theme options until I pasted into custom-functions.php
    add_filter( 'yt_site_dynamically_external_stylesheet', '__return_false' );
    but after that css is generating each time any page is loaded and the theme pastes the result inline into head section. I think this is what requests too much memory.

    So the point is to make the theme save options without add_filter.

    Of course I can edit custom-styles.css manually but somebody who reads this cannot.

    • This reply was modified 1 year, 5 months ago by  shalomanov.
    • This reply was modified 1 year, 5 months ago by  shalomanov.
  • #10061

    Jacob
    Staff
    Post count: 2312

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!