Error establishing a database connection

This topic is: Resolved

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!

Tagged: 

This topic contains 4 replies, has 3 voices, and was last updated by  Jacob 2 years, 4 months ago.

  • Author
    Posts
  • #3818

    Brian Le Vu
    Member
    Post count: 81

    Hello,

    Everytime there is a new published post, I got the error message “Error establishing a database connection” and website is donn for about 2 minutes.

    I think the problem with the cache plugin, tried test with different cache plugin but still not hope.

    The server explain because there are too many access to the database at the same time to cause this problem.

    Could you help me with this.

    Thank you,

    Brian

  • #3820

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #3823

    Brian Le Vu
    Member
    Post count: 81

    Hello @Maxxi,

    Thank you for looking at into the issue.

    About the issue while deleting. I saw you created a post and then delete it. When posts is created and published (only published) it takes about within 1 minutes to database to be disconnected (due to large number of request to database) I guess you delete the post right after you create it.

    The issue happen only when using the cache function. I tried with different cache plugin but it is still happening.

    The solution you sent me in wpbeginner website seem to fix the problem that permanent, the issue disconnect to database in my website is just temporarily until cache is cleared.,

  • #3831

    Brian Le Vu
    Member
    Post count: 81

    Hello @Maxxi,

    I tried everything as the tutorial link you reference. However, it couldn’t fix the issue and it said there is no issue with database.

  • #3842

    Jacob
    Staff
    Post count: 2323

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!