Bug – primary-bgcolor class syntax error

This topic is: Resolved

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!

This topic contains 3 replies, has 2 voices, and was last updated by  Max 1 year, 10 months ago.

  • Author
    Posts
  • #5475

    projectnursery
    Member
    Post count: 10

    Working on a child theme and trying to make sure I inherit settings colors for custom elements and such, I have successfully used the .primary-color class but there appears to be an error in the output for the .primary-bgcolor class, there’s a space before the hyphen that shouldn’t be there.

    Expected customized css output:

    .primary-bgcolor,.entry-tags a:hover { background-color: #ea4c89;}

    Actual customized css output:

    .primary -bgcolor,.entry-tags a:hover { background-color: #ea4c89;}

    Thanks.

  • #5504

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #6145

    projectnursery
    Member
    Post count: 10

    Returning to this issue, hoped to update it as resolved, but the issue has not been addressed. Some further details:

    file: wp-content/themes/yeathemes-sparkle/css/custom-styles.less line 524 currently reads:

    .primary
    -bgcolor,
    .entry-tags a:hover{
        background-color: @primaryColor;
    }

    but should read:

    .primary-bgcolor,
    .entry-tags a:hover{
        background-color: @primaryColor;
    }
  • #6160

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!