Bug – `function_exists()` missing from `yt_site_top_bar()`

This topic is: Resolved

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!

This topic contains 4 replies, has 2 voices, and was last updated by  projectnursery 1 year, 8 months ago.

  • Author
    Posts
  • #6147

    projectnursery
    Member
    Post count: 10

    I would like to customize the layout markup for the site top bar, most of the interface functions in the theme-interface.php include are wrapped with a if ( !function_exists( '<yt_interface_function_name>' ) ) : so the function can be overridden in child themes. This is wonderful, but it’s missing around the yt_site_top_bar function, approximately on line 30.

    Expected code:

    if ( !function_exists( 'yt_site_top_bar' ) ) :
    /**
     * Top bar
     *
     * @since 1.0.3
     */
    function yt_site_top_bar() {
        // ... function code
    }
    endif;

    Actual code:

    /**
     * Top bar
     *
     * @since 1.0.3
     */
    function yt_site_top_bar() {
        // ... function code
    }

    Thanks.

  • #6165

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #6339

    projectnursery
    Member
    Post count: 10

    Who said I didn’t? My report is on an inconsistency in the Sparkle methodology, not that I couldn’t solve the problem. Please feel free to mark as wontfix so I can know not to expect this to change in the future.

  • #6353

    Max
    Staff
    Post count: 3150

    Hey there, You must be logged in to view this reply!

    Login | Register | Forgot Password?

  • #7663

    projectnursery
    Member
    Post count: 10

    Just updated to the latest release (1.0.4.4) and saw this was added. Yay! Of course it’s need is probably nullified by the new templating (which I LOVE!) for theme functions. Thanks!

You must be logged in to reply to this topic.

This is a PRIVATE forum for verified users only, to view the replies/answers, you must be logged in!